WebPay::Mock の依存するWebMockのバージョンを2.0系に更新しました

WebPayのAPIレスポンスをテスト内で再現するためのRuby Gem、webpay-mockをバージョン0.3.0にアップデートしました。

今回の更新では、非互換な変更が加えられています。

  • 依存するWebMockのバージョンを2.0系に更新しました。これにより従来の記述方法では同じコードが正しく動作しないケースがあります
  • WebMockの更新に伴い、Ruby 1.9のサポートを外しました

なお、本件についてはGitHubにて@akito19 さんよりPull Requestを頂いたことにより更新に至りました。この場にて改めて御礼申し上げます。